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    Client

    Could not load type 'System.ServiceModel.ServiceHost' from assembly 'System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

    Cause

    You may receive this message if any of these conditions are true:

    • Running PowerShell cmdlets in PowerShell 7

    Resolution

    To resolve this problem, use any one of the following methods, depending on the cause of the problem:

    • Run the cmdlets in PowerShell 5.

    My package is not updating automatically

    Cause

    Your installation may not be updating automatically for any of the following reasons:

    • The Update Strategy is set to Manual instead of Automatic.
    • A specific version of the package is requested, instead of the latest version.
    • The client is in a deployment circle that is set to a specific version.
    • Client background service is not installed or not running.
    • Unable to resolve dependencies due to misconfiguration.
    • Error in the installation process.

    Resolution

    To resolve this problem, use any one of the following methods, depending on the cause of the problem:

    • Change Update Strategy:

      • In 1.3 and above: Open the client app, find the package or instance, hit Options, and change the Update Strategy to Automatic.
        • Start Menu -> Update Service -> Installed Components -> Package or instance -> Options -> Change Update Strategy to Automatic.
      • In 1.2.X and below, edit appropriate JSON file and set the UpdateStrategy property to Automatic.
        • C:\programdata\LS Retail\GoCurrent\Client\Installed\package-id.json"
        • C:\programdata\LS Retail\GoCurrent\Client\Installed\INSTANCENAME\package-id.json"
        • You may need to install the client service when changing the update strategy through JSON files, see below.
    • Change specific version to latest version

      • In 1.3 and above: Open the client app, find the package or instance, hit Update, and hit Install Latest. The install latest will not appear if it is already set to the latest version.
        • Start Menu -> Update Service -> Installed Components -> Package or instance -> Update -> Install Latest.
      • In 1.2.X and below: Edit the appropriate JSON file and set the VersionQuery property to an empty string.
        • NOTE: Do not add the VersionQuery property if it is not already present.
        • NOTE: If this is an instance, you may need to update multiple JSON files.
        • C:\programdata\LS Retail\GoCurrent\Client\Installed\package-id.json"
        • C:\programdata\LS Retail\GoCurrent\Client\Installed\INSTANCENAME\package-id.json"
    • Check if a deployment circle is configured for the target package.

      • Verify if the client is in any deployment circles and if the target version for the circle is correct.
      • Verify if the outermost deployment circle is set to the correct version.
    • To check for a dependency error, open the client app, locate the package or instance, and select Update. If a dependency error exists, an error will occur.

      • Start Menu -> Update Service -> Installed Components -> Package or instance -> Update.
    • Check if an error occurs during the installation:

      • In the server UI, go to the Installs page to see if there are any installation attempts by the client.
      • Check the logs, in C:\programdata\LS Retail\GoCurrent\Client\Log, sort by date modified and search for the latest LSRetail.UpdateService.Client.Service.exe- log file.
    • Verify if the client background service is installed and operational:

      • Open the Windows Services and check if the LS Go Client Client Service exists and running.
      • If not, you can install the service via PowerShell as follows:
      Install-UscPackage -PackageId 'go-current-client-service'
      
    Note

    To trigger an update immediately, restart the client service.

    Failed to download file "QnRQX4/1RnBtgaYjKaCjbG3BuW0" from server "04fd9496-4fe0-44f8-bebb-fccfcbcbbb21"

    Cause

    You may receive this message or a similar message if any of these conditions are true:

    • Files are missing on the server.

    Resolution To resolve this problem, use any one of the following methods, depending on the cause of the problem:

    • See here for more information on how to resolve this issue.
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